Logjam Vulnerability already corrected on the PH infrastructure

There have been numerous vulnerabilities related to SSL this year; Heartbleed / FREAK / Ghost / Poodle / …

A new security vulnerability has been discovered in the 512bits SSL / TLS encryption system.

If you have a hosting with us; wether it is a shared hosting, reseller, VPS Ecommerce, you do not have to worry, because we have already taken the lead.

PlanetHoster has been generating for almost a year SSL certificates with a size of at least 2048bits even 4086bits in some cases. Additionally, our servers are now configured to accept connections using old unreliable security protocols. We also wish to emphasize our partnership with Symantec allows us to get a better understanding on this matter.

If your site does not use HTTPS, we recommend you read this article: https://blog.planethoster.net/en/a-padlock-on-your-site-for-added-security/

Remember also that if you have a hosting plan Shared Hybrid Unlimited, you get a free SSL certificate with your purchase.


facebooktwitterlinkedingoogle

Previous Previous article
Next article Next


Leave a Reply

Your email address will not be published. Required fields are marked *