Mise à jour – Passage de la version native PHP 5.6 à PHP 7.0

Bonjour à tous,

Ce message est pour vous informer que les infrastructures partagées suivantes passeront de PHP 5.6 à PHP 7.0 par défaut à compter du 13 juin 2017. PHP 5.6 arrive en « fin de vie » (EOL) bientôt et puisque nous tenons à la sécurité de votre hébergement, nous prenons les mesures nécessaires, et ce en avance!

Normalement, la majorité des CMS/Scripts récents supportent PHP 7.0, nous vous invitons tout de même à revérifier que votre CMS/Extensions et thème à jour afin de vérifier que ceux-ci soient bien compatible avec cette version ! (Voir PHP-Selector dans le cPanel)

Pour information cette version de PHP permet d’avoir jusqu’à deux fois plus de performance comparativement à PHP5.6 et dans le futur, il devrait être possible de choisir des version de PHP différentes pour des domaines supplémentaires.

Voici, le calendrier des mises à jour qui seront effectuées:

pern.planethoster.net => À partir du 13 Juin 2017 (ok)
thorni.planethoster.net => À partir du 13 Juin 2017 (ok)
fate.fr.planethoster.net => À partir du 20 Juin 2017 (ok)
pluto.ca.planethoster.net => À partir du 20 Juin 2017 (ok)
hari.fr.planethoster.net => À partir du 26 Juin 2017 (ok)
riet.planethoster.net => À partir du 27 Juin 2017 (ok)
mars.fr.planethoster.net => À partir du 28 Juin 2017 (ok)
kais.fr.planethoster.net => À partir du 3 Juillet 2017 (ok)
folca.planethoster.net => À partir du 4 Juillet 2017 (ok)
fornost.planethoster.net => À partir du 4 Juillet 2017 (ok)
nova.planethoster.net => À partir du 5 Juillet 2017 (ok)
davis.fr.planethoster.net => À partir du 5 Juillet 2017 (ok)
duncan.planethoster.net => À partir du 19 Juillet 2017 (ok)
uteda.fr.planethoster.net => À partir du 20 Juillet 2017 (ok)
lyman.fr.planethoster.net => À partir du 20 Juillet 2017 (ok)
lucy.fr.planethoster.net => À partir du 24 Juillet 2017 (ok)
mercure.ca.planethoster.net => À partir du 25 Juillet 2017 (ok)
otos.planethoster.net => À partir du 26 Juillet 2017 (ok)
fengel.fr.planethoster.net => À partir du 26 Juillet 2017
teta.fr.planethoster.net => À partir du 1 Aout 2017
lorie.fr.planethoster.net => À partir du 1 Aout 2017
gorgun.fr.planethoster.net => À partir du 1 Aout 2017
mongo.planethoster.net => À partir du 8 Aout 2017
marvin.fr.planethoster.net => À partir du 8 Aout 2017
wall.fr.planethoster.net => À partir du 9 Aout 2017
nali.fr.planethoster.net => À partir du 15 Aout 2017
world.fr.planethoster.net => À partir du 15 Aout 2017
lune.fr.planethoster.net => À partir du 16 Aout 2017
aiglos.fr.planethoster.net => À partir du 22 Aout 2017
cloud101.ca.planethoster.net => À partir du 22 Aout 2017
neptune.ca.planethoster.net => À partir du 23 Aout 2017

Pour les clients ayant un serveur VPS/HybridCloud ou encore un serveur dédié, il est possible dans le cadre de l’infogérance de rendre le serveur près de 9 fois plus performant en activant PHP7 couplé à PHP-FPM. De plus grâce à cette mise à jour, il est maintenant possible d’avoir plusieurs versions de PHP sur le même serveur et cela en un seul clic ! Demandez donc votre mise à jour de votre infrastructure via ce lien: Contacter le support technique

Si vous avez des questions, nous restons à votre disposition,

Cordialement,

Équipe de PlanetHoster


facebooktwitterlinkedingoogle

Previous Article précédent
Article suivant Next


  1. Superbe initiative, PHP7 est maintenant la version que tous les sites devraient utiliser pour maintenir leurs sécurités et aussi la réactivité des temps de chargements.

  2. Puisque vous migrer, il serait possible de passer de PostgreSQL 8.4 à une version plus récente ? au hasard la 9.6.

    Merci

    1. Bonjour MaitrePylos,

      Pouvez-vous me dire si vous êtes toujours sur une ancienne offre d’hébergement de type Hybride (Mono, Multi, Illimité) ou VPS? Si oui, ces infrastructures utilisant CentOS 6 , celle-ci sont effectivement sur PostgreSQL 8!

      Je viens de faire une vérification sur un serveur World ou encore HybridCloud (qui utilisent CentOS 7) et ceux-ci on bien la version 9 de PostgreSQL.

      Je vous invite à contacter notre support afin que nous regardions si nous pouvons vous migrer vers une infrastructure plus récente.
      Bien à vous.
      Quentin

  3. Comment savoir a quel domaine on appartient ? (neptune.ca…, fate.fr…)
    Je ne trouve pas l’information dans mon espace client.

    Merci.

    1. Bonjour Jérémy,

      Très bonne question ! Pour cela je vous invite à regarder IntoDNS qui permet de voir quel sont les nameserveurs/MX/A de votre domaine

      Dans votre cas votre domaine est kheopsinternational.ca il faut donc se rendre sur https://intodns.com et indiquer « kheopsinternational.ca » + Report

      Une fois cela effectué, vous allez pouvoir voir que vous utilisez les NS records du vps819.ns.planethoster.net ! Si vous voyez les serveur de nom Anaycast de PlanetHoster NS(A/B/C).planethoster.net -> Il faut à ce moment là regarder dans la partie « MX » l’encadré « Reverse MX A records (PTR) » qui indiquera le nom du serveur partagé !

      Si vous avez le moindre problème, le support est disponible et ce 24/7 !
      Quentin

  4. Bonjour,

    Juste pour confirmation et m’assurer d’avoir bien compris :
    J’ai plusieurs sites WordPress sur mon hébergement mutualisé (hybride multi), ils sont tous parfaitement à jour (cms, extensions et thèmes).
    Pour vérifier la compatibilité, dans PHP Selector je dois activer (set current) la version 7 ou 7.1, si j’observe un problème je peux revenir à la version précédente sans que les sites aient été corrompus d’une quelconque manière ?

    Merci

    1. Bonjour Sébastien,

      Oui c’est tout à fait cela, il vous est possible de procéder à une vérification en passant de la version native à la version PHP7.0 afin de tester que toutes vos fonctionnalités sont bien compatibles.

      Si tels est le cas, je vous invite à revenir sur la version native qui est la version recommandée par PlanetHoster et qui au fil des années évolue !

      Pour information, le changement de version de PHP n’altère en rien vos scripts PHP ou encore votre base de donnée -> C’est donc sans aucuns risque que vous pouvez faire ce changement de version.

      Bien à vous.

      1. Merci Quentin pour ces précisions.

        Novice en la matière, j’ai une dernière question : préconisez-vous davantage la version 7.0 plutôt que la version 7.1, est-ce significatif ?

        1. La version PHP7.1 est tout juste sortie en décembre 2016, celle-ci n’a donc que 6 mois à son actif.

          Nous recommandons donc à l’heure actuelle un passage sur PHP7.0 et non vers 7.1 qui n’offre guère d’avantage supplémentaire.

          N’oubliez pas que la version appelée « Native » dans votre PHP-Selector ne cessera jamais d’évoluer a fils des années, c’est donc la version que PlanetHoster recommande à ces clients pour restera à jour et pouvoir bénéficier des dernières avancées technologiques stables.

  5. pas tout à fait la dernière question…

    J’ai testé avec la version 7.0, les sites marchent en l’état je ne cherche donc pas plus loin.

    Cependant, quand je l’ai définie comme version actuelle, un ensemble de cases à cocher m’ont été proposées (des extensions PHP ?). J’ai tout coché, à la suite de quoi j’ai eu un message notifiant des conflits ; les 3 items suivants ont été décochés automatiquement : gmagick, mysqli, pdo_mysql

    Comme mes sites fonctionnent, je vais à priori rester sur ce paramétrage, je ne tiens pas compte de ces 3 items décochés ?

    1. Bonjour Sébastien,

      Si vous avez cochez PHP7.0 et que vos sites continuent à fonctionner c’est que ceux-ci sont bien compatible !

      Concernant les extensions PHP, par défaut le PHP-Selector va automatiquement charger les modules qui sont le plus demandés -> Il est effectivement possible d’en rajouter mais certains peuvent effectivement être incompatible entre elles.

      Pour information, je vous recommande de rester en version Native afin que les prochaines années vous puissiez continuer à passer sur des versions plus récentes encore.

      Bien à vous,
      Quentin

  6. Bonjour Quentin C. et Gabriel P.
    Malgré tous vos efforts vous n’avez pas réussi à nous passer en PHP 7, notre version de Prestashop étant vraiment trop ancienne.
    Je tiens malgré tout à vous féliciter pour vos compétences et vous remercier pour votre travail, votre disponibilité et la qualité de vos services!
    Top support!!!

  7. Bonjour,
    Depuis la mise à jour notre boutique affiche page blanche (erreur 500)..
    Nous étions sur une ancienne version de prestashop, est-ce que cela est dû ?? Je ne sais pas quoi faire depuis hier.
    Je suis novice, Merci d’avance.

    1. Bonjour Irlinger,

      Effectivement si votre CMS n’est pas à jour, il est possible que celui-ci ne soit pas pleinement compatible avec PHP7 ! Il est donc recommandé de planifier une mise à jour afin d’assurer la performance et sécurité de vos informations.

      Après la très bonne nouvelle est que PlanetHoster continue à supporter les anciennes versions et cela de manière totalement sécurité car les vulnérabilités sont aussi backporté dans plus veilles versions ! Vous pouvez dès lors aller dans votre cPanel et cliquez sur « Choisir version PHP » pour revenir en PHP5.6

      Vous trouverez + d’informations à ce sujet ici: https://www.youtube.com/watch?v=aLyViaSbJK8

      Sinon le support est aussi disponible!

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *